re = /\b(?=[A-Z]*[a-z])(?=[a-z]*[A-Z])([a-zA-Z]+)\b/m
str = 'Just some random text
to Test a RegEx
that should extract
Words and WordS
but not words and WORDS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end