$re = '/^ABC[0-9]{3}$/m';
$str = 'ABC000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);