#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/|\/\/)?(?:(?:www\.|m\.)?youtube(?:-nocookie)?\.com\/(?:(?:vi?|e|embed)\/([\w-]{11})|(?:watch|embed|attribution_link)?\?\S*?(?:(?<=\?v=|&v=)|(?<=\?vi=|&vi=))([\w-]{11}))|youtu\.be\/(?:([\w-]{11})(?!\S*v=)|\S*?(?:&v=|\?v=)([\w-]{11})))(?:[^\w-]\S*)?$"
Local $sString = "My tests" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?t=10&v=m_KBvP0_8Tc&sss" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/watch?v=e70VCVR-oQo&v=asdssssssss" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/watch?t=10s&v=e70VCVR-oQo" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/aaaaaaaaaaa?t=10&v=e70VCVR-oQo&v=asdssssssss" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?t=10&v=e70VCVR-oQo&v=asdssssssss" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/oTJRivZTMLs&t=10" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"List of YouTube links I found online" & @CRLF & _
"" & @CRLF & _
"//www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/embed/XNHjiJVz0ks?feature%3Doembed&display_name=YouTube&url=https://www.youtube.com/watch?v%3DXNHjiJVz0ks&image=https://i.ytimg.com/vi/XNHjiJVz0ks" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=-wtIMTCHWuI/vi/XNHjiJVz0ks" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=m_KBvP0_8Tc&v=asdssssssss" & @CRLF & _
"" & @CRLF & _
"https://m.youtube.com/watch?v=m_kbvp0_8tc" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/-wtIMTCHWuI" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=m_KBvP0_8Tc" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/embed/0zM3nApSvMg?rel=0" & @CRLF & _
"" & @CRLF & _
"//www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0" & @CRLF & _
"" & @CRLF & _
"https://www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=6dwqZw0j_jY&feature=youtu.be" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=peFZbP64dsU" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/v/peFZbP64dsU?feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/?vi=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/vi/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/embed/dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/?v=dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=oTJRivZTMLs&feature=youtu.be" & @CRLF & _
"" & @CRLF & _
"http://youtu.be/oTJRivZTMLs&feature=channel" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/embed/oTJRivZTMLs?rel=0" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/vi/oTJRivZTMLs&feature=channel" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/?v=oTJRivZTMLs&feature=channel" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/?feature=channel&v=oTJRivZTMLs" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/?vi=oTJRivZTMLs&feature=channel" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/watch?v=oTJRivZTMLs&feature=channel" & @CRLF & _
"" & @CRLF & _
"http://youtube.com/watch?vi=oTJRivZTMLs&feature=channel"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")