$re = '/(?<months>December)|^(next)\s(\k<months>)/m';
$str = 'next December
December 2020 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);