$re = '/[\x{D800}-\x{DBFF}][\x{DC00}-\x{DFFF}]/';
$str = '😋
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);