package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+`)
var str = `Catch 22 Slaughterhouse 5 Fahrenheit 451`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}