import Foundation
let pattern = #"(\?|\&)([a-z_]+=)([a-z])([^&]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://www.google.com/search?q=hello+there&oq=hello+there&aqs=chrome..69i57j0l5.2394j0j7&sourceid=chrome&es_sm=122&ie=UTF-8&qscrl=1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)