$re = '/^((?!Drive).)*$/';
$str = 'EFI Internal Shell
EFI Hard Drive
EFI Drive
Cat
Drive';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);