re = /^((?!Drive).)*$/m
str = 'EFI Internal Shell
EFI Hard Drive
EFI Drive
Cat
Drive'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end