$re = '/^(?![a-z]+$)[0-9a-z()+ -]+$/im';
$str = '8(911) 000 00-00
ASDFGHHHJ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);