re = /<\/item>(((?!item).)*?)\s*?<\/body>/i
str = '<body>
<item>abc</item>
<item>def</item>
unparsable rest
</body>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end