re = /^(?!(?:.{13,}|.{1,2})$)(?:([a-z0-9]+)|([a-z0-9]*[\.\_][a-z0-9]*))$/m
str = 'ab
abc.asdasdsaddsaasdad
asd.asdasdsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end