$re = '/[A-Z]([A-Za-z0-9]+)*/';
$str = 'test283
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);