re = /(\w+)\s([\d]+)(%|\w+)\s(\w+)\s(\w+)\sx\s(\d)\/(\d+)/
str = 'hydrochlorothiazide 25ml po od x 2/52'
# Print the match result
str.match(re) do |match|
puts match.to_s
end