using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--[^-]+stylesheet.+?-->";
string input = @"<!-- The quick brown fox
jumps over the lazy dog -->
<!--[if IE 7]>
<link rel=""stylesheet"" type=""text/css"" href=""/supersheet.css"" />
<![endif]-->
<!-- Pack my box with five dozen liquor jugs -->";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}