import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(youtu(?:\\.be|be\\.com)\\/(?:.*v(?:\\/|=)|(?:.*\\/)?)([\\w'-]+))";
final String string = "http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo\n"
+ "http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I\n"
+ "http://www.youtube.com/user/SilkRoadTheatre#p/a/u/2/6dwqZw0j_jY\n"
+ "http://youtu.be/6dwqZw0j_jY\n"
+ "http://www.youtube.com/watch?v=6dwqZw0j_jY&feature=youtu.be\n"
+ "http://youtu.be/afa-5HQHiAs\n"
+ "http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo?rel=0\n"
+ "http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I\n"
+ "http://www.youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "http://www.youtube.com/watch?v=peFZbP64dsU";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}