package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[^>]*>`)
var str = `текст перед таблицей <table>содержимое таблицы</table> и после`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}