#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w]+,[\w]+\s+[\w]\s+[\d]{1,2}[\S\s\.]+[\d]{4})"
Local $sString = " TC TOURISTIK GMBH HOTEL LIST (L/6X) AS OF : 25.07.2016" & @CRLF & _
" L/CENPA ARRIVAL-LIST COPY : 001 " & @CRLF & _
" ARRIVAL:08.08.2016 14 DAYS BEFORE ARRIVAL PAGE : 1173/ 9" & @CRLF & _
" ADDRESS : L/CENPA CODE : 1FCH7 " & @CRLF & _
" CENTER PARCS CENTER PARCS LE LAC D'AILETTE " & @CRLF & _
" PB1342/ACCOUNTS RECEIVABLE BTB " & @CRLF & _
" B NL-3000 ROTTERDAM 1FCH CHAMPAGNE/RHE " & @CRLF & _
" --------------------------------------------------------------------------------" & @CRLF & _
" POS NO TRAVELLER SEX BOARD " & @CRLF & _
" I STATE I I AGE I BOOKING-DATE " & @CRLF & _
" I I I I I DURATION I I " & @CRLF & _
" I I I I I I ARRIVAL/DEPARTURE " & @CRLF & _
" V V V V V V V V V " & @CRLF & _
" --------------------------------------------------------------------------------" & @CRLF & _
" ABBREVIATIONS FOR BOARD: OV=WITHOUT CATERING, UF=BREAKFAST, HP=HALF-BOARD, " & @CRLF & _
" VP=FULL-BOARD, AI=ALL INCLUSIVE, LP=CATERING AS DESCRIBED " & @CRLF & _
" --------------------------------------------------------------------------------" & @CRLF & _
" 1FCH7 G CP LE LAC D'AILETTE MDWK / SSR-DESK BELGIUM " & @CRLF & _
" THOMAS COOK BE BUNGALOWS " & @CRLF & _
" 6 H ***BUNGALOWS WITH 4 ROOMS*** " & @CRLF & _
" BATH, SHOWER, WC, LA387 PREMIUM " & @CRLF & _
" 13501629 FRENCH/UNITS: 01 " & @CRLF & _
" 1 ORGERIT,BENOIT M 00 4 08.08-12.08 OV 19.07.2016 " & @CRLF & _
" 2 MACK,KRISTYNA F 00 4 08.08-12.08 OV 19.07.2016 " & @CRLF & _
" 3 ORGERIT,LILOU C 09 4 08.08-12.08 OV 19.07.2016 " & @CRLF & _
" 4 ORGERIT,TOM C 07 4 08.08-12.08 OV 19.07.2016 " & @CRLF & _
" 5 ORGERIT,YANIS C 03 4 08.08-12.08 OV 19.07.2016 " & @CRLF & _
" 6 COLSON,LOUKA C 07 4 08.08-12.08 OV 19.07.2016 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")