$re = '/^(?:(?:^|\/|(?:(?:(?!(?:^|[\\\\\/])\.).)*?)\/)path(?:\/(?!\.)(?:(?:(?!(?:^|[\\\\\/])\.).)*?)|$))$/';
$str = 'C:\\Users\\user\\Projects\\project\\path\\image.jpg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);