import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+(?:\\.\\d{1,2})?)\\|([a-zA-Z]{2}(?:(?:\\+\\d+(?:\\*\\d+)?)|(?:\\*\\d+(?:\\+\\d+)?))?(?:,[a-zA-Z]{2}(?:(?:\\+\\d+(?:\\*\\d+)?)|(?:\\*\\d+(?:\\+\\d+)?))?)*)(?: +(.+))?$";
final String string = "62.00|LQ+2*2,FP,MD*3\n"
+ "30|LQ \"Burgers\"\n"
+ "35.15|LQ*2,FP+2*4,MD*3+4 \"Potatoes\"\n"
+ "35.15|LQ,FP,MD\n"
+ "35.15|LQ*2,FP+2+4,MD*3+4 \"Potatoes\"\n"
+ "35.15|LQ*2,FP+2*4,MD*3*4 \"Potatoes\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}