import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[А-Я]\\w+";
final String string = "Регулярные выражения представляют собой похожий, но гораздо более сильный инструмент \n"
+ "для поиска строк, проверки их на соответствие какому-либо шаблону и другой подобной \n"
+ "работы. Англоязычное название этого инструмента — Regular Expressions или просто RegExp. \n"
+ "Строго говоря, регулярные выражения — специальный язык для описания шаблонов строк.\n\n"
+ "АААА аааа АаАаАаАа 123 123 12345 11223344\n"
+ "А1Б2В3 АА11 ББ22ВВ 33ГГ44\n\n"
+ "Тест! Ещё! Даёшь! ЁЁЁёёё\n\n"
+ "QwertyЙцукен\n\n"
+ "+-,/[](), *** (***), a*(b+[c+d])*e/f+g-h\n\n"
+ "!!\"\"\"####$$$$$%%%%%&&&'''(((())***++++,,,,,-----..//:::;;;;<<<<<===>>>????\n"
+ "@@@@@[[[[\\\\\\]]]]]^^^__`````{{{{|||||}}}}}~~~~~\n\n"
+ "<a href=\"#10\">10: CamelCase -> under_score</a>;\n"
+ "<a href=\"#11\">11: Удаление повторов</a>;\n"
+ "<a href=\"#12\">12: Близкие слова</a>;\n"
+ "<a href=\"#13\">13: Форматирование больших чисел</a>;\n"
+ "<a href=\"#14\">14: Разделить текст на предложения</a>;\n"
+ "<a href=\"#15\">15: Форматирование номера телефона</a>;\n"
+ "<a href=\"#16\">16: Поиск e-mail'ов — 2</a>;\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}