$re = '/(?:\G(?!\A)|\(),?\K\d+/';
$str = 'Some text 11 have number 12 (11,12,13)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);