package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z]+`)
var str = `my&friend&Paul has heavy hats! &`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}