$re = '/[A-Za-z0-9]*\.m8\.za\.2mdn\.net/';
$str = 'http://1.m8.za.2mdn.net/blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);