$re = '~[^/]+/$~im';
$str = '/my/long/path/which/will/never/ends/';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;