package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\d|+][0-9]*$`)
var str = `+94348758934758
094348758934758
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}