import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*spe*d)(?=.*engine).*";
final String string = "Spd_Engine #Ok\n"
+ "speedengine #Ok\n"
+ "enginespd #Ok\n"
+ "Engine_speed #Ok\n"
+ "aps_speed_engine #Ok\n"
+ "engine_speed #Ok\n"
+ "engine_trq #Not Ok\n"
+ "speed_rpm #Not Ok\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}