$re = '/^[\w-.+]+@(?:[\w-]+.)+[\w-]{2,4}$/m';
$str = 'name+thing@gmail.com
f+o+o@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);