using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^data:([A-Za-z-+\/]+);base64,(.+)$";
string input = @"data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABDgAAAeACAYAAAArYecKAAAABmJLR0QA/wD/AP+gvaeTAAAgAElEQVR4nKy9W4LkOK4saIAi";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}