using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+) (?=(?s:.)*(\1.*)).*";
string input = @"user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user3 jan/12/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user6 aug/06/06
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 aug/12/12
user5 feb/13/13
user1 dec/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user2 jun/15/14";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}