# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[(.*?)\])(\((.*?)\))"
test_str = ("Di [Clash Of Clans](https://jalantikus.com/games/clash-of-clans/), Trophy merupakan sebuah piala yang digunakan untuk menentukan peringkat kalian di game COC tersebut. Namun selain itu kalian juga bisa mendapatkan hadiah gems di beberapa tingkat tertentu seperti Crystal League, Master League, dan Champion League. Sungguh menyenangkan bukan? Nah pada artikel ini, JalanTikus akan memberi kalian tips hunting trophy menggunakan [Xmodgames](https://jalantikus.com/apps/xmodgames/). Untuk menggunakan [Xmodgames](https://jalantikus.com/apps/xmodgames/) pastikan Android kamu sudah di-root. Jika belum, kamu bisa baca : \n\n"
"1. [Cara Mudah Root Semua Jenis Android Tanpa PC dengan Framaroot](https://jalantikus.com/tips/cara-mudah-root-semua-jenis-android-tanpa-pc-3897/)\n"
"2. [Cara Root Semua Jenis Android dengan Towelroot](https://jalantikus.com/tips/cara-root-semua-jenis-android-dengan-towelroot/)\n"
"3. [Cara Mudah Root Semua Jenis Android dengan KingoApp](https://jalantikus.com/tips/cara-mudah-root-semua-jenis-android-dengan-kingoapp/)\n\n"
"### **Cara Hunting Trophy Clash Of Clans**\n"
"- Pastikan yang kamu install adalah Clash of Clans versi terbaru.\n"
"[app]1148[/app]\n"
"- Download dan install **Xmodgames** versi terbaru di Android kamu.\n"
"[app]1855[/app]\n"
"- Buka Xmodgames-nya, pastikan akses root sudah diberikan. Pilih game [Clash Of Clans](https://jalantikus.com/games/clash-of-clans/).\n"
"\n"
"- Kemudian, Install Mod nya sampai berhasil (Cuma beberapa menit kok). Jika sudah klik Launch agar MOD dapat berjalan saat game dimainkan.\n"
"\n"
"- Setelah masuk ke dalam game, Akan muncul robot Xbot di sebelah kanan layar. Klik robotnya, lalu pilih menu Xmod.\n"
"\n"
"\n"
"- Di **Xmodgames** terdapat banyak pilihan menu, Namun kali ini kalian scroll kebawah hingga menemukan tulisan "**Townhall level**" dan "**Townhall Near Edge**". Nah Maksud dari "**Townhall level**" adalah batas maksimum TH yang akan dicari pada saat attack, Kalau saran Jaka sih mending setting ke 10 karena kita hanya sedang mencari Trophy nya saja. Dan Maksud dari '**Townhall Near Edge**' adalah jarak antara TH dengan pinggiran base. Jadi angka tersebut adalah jarak kotak-kotak yang biasanya ada di base, Kalau saran Jaka ya disetting ke 10 aja biar cepet dapetnya.\n"
"\n"
"- Lalu kalian scroll kebawah lagi hingga menemukan empat tulisan yaitu : "**Meet All Conditions**", "**Auto Search**", "**Play Sound**", dan "**Keep Active**". Nah kalian ON kan semua tulisan tersebut, fungsinya untuk memulai **COC** agar mencari base lawan secara otomatis dan apabila ketemu akan berbunyi jadi kalian dapat dengan mudah mengetahuinya, dan kalian tidak usah khawatir jika Android nya akan mati. Biasanya pada proses mencari memakan sedikit waktu sekitar 3-5 menit.\n"
"\n"
"- Nah jika sudah ketemu, Tinggal serang aja deh TH yang berada diluar base hanya dengan bermodal Archer secukupnya. Lakukan cara ini berulang-ulang agar mendapatkan Trophy yang banyak.\n"
"\n"
"\n\n"
"Dengan demikian, kalian semua dapat dengan cepat mendapatkan trophy yang kalian inginkan. Selamat Mencoba !\n\n"
"### **Tambahan**\n\n"
"Jika kamu mendapatkan kesulitan tentang Clash of Clans, jangan sungkan untuk email kami di **coc@jalantikus.com**. Kami siap membantumu!\n\n"
"Jika kamu sudah **TH 8 Maksimal**, jangan lupa untuk gabung juga di Clan JalanTikus.com (**#8PVVRRJL**).\n"
"\n"
"Untuk kamu yang belum bisa masuk Clan JalanTikus.com 1. Kamu bisa masuk ke **Clan JalanTikus.com2** (**#Y8HCCRRQ**)\n"
"\n\n"
"Menemukan masalah dalam bermain Clash of Clans? Jangan lupa untuk email tim JalanTikus di **coc@jalantikus.com**. Kami siap membantumu! Pernahkan Android kamu merasa Lambat, Lemot, Aplikasi Tidak merespon?\n"
"mungkin Hal tersebut sangat sering kita jumpai\n"
"Namun apakah hal tersebut dapat diatasi?\n\n"
"Ya sangat bisa sekali!\n\n"
"Lalu bagaimana cara mengatasinya??? Berikut saya berikan tips-tipsnya agar Android kamu tidak gampang lemot.\n\n"
"Berikut tips tipsnya:\n\n"
"1. jangan install Aplikasi Cleaner seperti 360 Security, Clean Master DU Speed booster.\n"
"\n"
"Pasti kalian berfikir "Lohh kenapa? Kan aplikasi tersebut dapat membuat HP android menjadi tidak lemot."\n"
"Ya memang Aplikasi tersebut membuat HP android menjadi ringan, Namun tanpa kita sadari Aplikasi tersebut justru banyak memakan RAM saat berjalan yang akan membuat HP android anda menjadi lemot.\n\n"
"2. uninstall Aplikasi yang tidak penting\n"
"Selain untuk menghemat penyimpanan android, uninstal aplikasi yang tidak penting dapat menghemat RAM, karena tanpa kita sadari Aplikasi yang tidak digunakan pun ikut berjalan yang dapat menyebabkan RAM berkurang tanpa kita ketahui.\n"
"\n"
"3. Gunakan Aplikasi Versi Lite.\n"
"sama seperti nomer 2, penggunaan aplikasi versi lite akan menghemat RAM, itu karena Aplikasi yang bersifat Lite biasanya lebih ringan dibanding versi yang bukan Lite.\n"
"\n"
"4. lakukan Restart HP anda secara rutin.\n"
"Ini berfungsi agar semua proses akan dalam android ditutup dan membuat android anda menjadi fresh kembali.\n"
"\n"
"5. Gunakan Aplikasi Swapper2 [Root Mode]\n"
"Aplikasi ini berfungsi sebagai pembantu kinerja RAM. sayangnya, tidak semua HP android dapat menggunakan aplikasi tersebut.\n"
"\n"
"Sekian Tips agar HP android anda tidak lemot!\n"
"SELAMAT MENCOBA :)")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.