import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((.*)[\\*\\)?]";
final String string = "1-3:0.2.8(42)\n"
+ "0-0:1.0.0(160615075410S)\n"
+ "0-0:96.1.1(4530303034303031353038323431303133)\n"
+ "1-0:1.8.1(004778.237*kWh)\n"
+ "1-0:2.8.1(000000.000*kWh)\n"
+ "1-0:1.8.2(001579.915*kWh)\n"
+ "1-0:2.8.2(000000.000*kWh)\n"
+ "0-0:96.14.0(0002)\n"
+ "1-0:1.7.0(00.265*kW)\n"
+ "1-0:2.7.0(00.000*kW)\n"
+ "0-0:96.7.21(00002)\n"
+ "0-0:96.7.9(00001)\n"
+ "1-0:99.97.0(1)(0-0:96.7.19)(151125043910W)(0048354692*s)\n"
+ "1-0:32.32.0(00000)\n"
+ "1-0:32.36.0(00000)\n"
+ "0-0:96.13.1()\n"
+ "0-0:96.13.0()\n"
+ "1-0:31.7.0(002*A)\n"
+ "1-0:21.7.0(00.265*kW)\n"
+ "1-0:22.7.0(00.000*kW)\n"
+ "0-1:24.1.0(003)\n"
+ "0-1:96.1.0(4730303136353631323035393231393134)\n"
+ "0-1:24.2.1(160615070000S)(00251.225*m3)";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}