re = /{[^'"}]*(?:('|").*\1)*[^'"}]*}/
str = 'obj {= {str: \'Вмухаха}\';} fjkds}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end