$re = '/\b([A-Z]{2})((?![A-Z]{10}\b)[A-Z0-9]{10})\b/';
$str = 'ABCDEFGHIJKL US45256BAD38 US64118Q1076 XS0884410019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);