re = /(?im)^(?=\*|.+\*$)(?:\*[.-]?)?[a-z0-9](?:[a-z0-9-]*[a-z0-9])?(?:\.[a-z0-9](?:[a-z0-9-]*[a-z0-9])?)*(?:[.-]?\*)?$/m
str = '*test.com
*.test.com
*test
test.*
test*
*test*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end