$re = '/up (.*)$/m';
$str = 'Cisco Adaptive Security Appliance Software Version 9.12(1)2
ASAv1 up 23 mins 50 secs
Serial Number: 9A2AL26E95V';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);