# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
[\p{L},\h]+
\(1[0-8]\d{2}\)
"""
test_str = "Прп. Моисея Мурина (ок. 400). Обре́тение мощей прп. Иова Почаевского (1659). Собор преподобных отцов Киево-Печерских, в Дальних пещерах (прп. Феодосия) почивающих. Прп. Саввы Крыпецкого, Псковского (1495). Прав. Анны пророчицы, дщери Фануилевой, встретившей Господа Иисуса Христа в храме Иерусалимском (I). Мц. Шушаники, кн. Ранской (V) (Груз.). Сщмч. Алексия Будрина (1918); прмчч. Казанских: Сергия Зайцева, Лаврентия Никитина, Серафима Кузьмина, Феодосия Александрова, Леонтия Карягина, Стефана, Георгия Тимофеева, Илариона Правдина, Иоанна Сретенского и Сергия Галина (1918). Прп. Исаакия Оптинского (1894). Сщмч. Александра Медведева диакона (1918); сщмч. Николая Георгиевского пресвитера (1931); сщмч. Василия Сокольского пресвитера (1937). Грузинской иконы Божией Матери (1650)."
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.