import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*(\\w+)\\s*=\\s*(?:'((?:[^'\\\\]|\\\\\")*)'|\"((?:[^\"\\\\]|\\\\\")*)\"?|(\\w+)))";
final String string = "{keyword name1=val1 name2='val2' name3=\"val3\" name4=\"Isn't this OK?\" name5=okay name6='Isn\\'t' name7=\"A \\\"quote\\\"\"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}