package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[^\-][a-zA-Z0-9-]{3,63}\.cz$)`)
var str = `dsfn.cz`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}