const regex = new RegExp('(^(?:List\\sof\\sFigures?|Figures?\\sLegends?|Captions?|List)\\s*:?(?:(?!^)[^\\n]+|(?!\\n{4,}|\\n\\w+\\s*\\w+\\s*:?\\s*$)\\n|Fig)*)', 'gmis')
const str = `List of Figures:
Figure 1 Kalpakkam study area and locations of borewell and surface water sampling points. Low lying area on the western side is clearly delineated.
Figure 2 displays Local meteoric water line (in thick line) of Chennai region (Bhishm Kumar et al., 2010) and Evaporation line (in dashed line). The stable isotope (δD and δ18O) composition of borewell and surface water body samples are plotted to analyse their origin.
Not figures:
Figure 3 depicts the plot of salinity vs. δD for various borewell and surface water samples. It can be seen that borewell (freshwater) and lake water samples are clustered at the lower range of salinity and δD levels. Similarly, the saline water samples are clustered at the higher range of salinity and δD levels.
Figure 4 depicts the plot of salinity vs. δ18O for various borewell and surface water samples. It can be seen that borewell (freshwater) and lake water samples are clustered at the lower range of salinity and δ18O levels. Similarly, the saline water samples are clustered at the higher range of salinity and δ18O levels.
Not starting with figure`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}