$re = '/(?<!a)aa(?!a)/';
$str = 'Baal! Hooraaay!';
$subst = "aaa";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;