re = /^(?!.*[^0-9.,\n]).*$/m
str = '121222222222222222222222222222222222222222222222222222222222222222222.1212121211111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end