use strict;
my $str = 'Text starts with (Regex Expression /)
This test is to help with the Regex when the symbol is / and looks for any text where the text is contained
Change the box above to have the word the and it will match all the thes in the text, this is case sensitive.
-------------
Text starts with (Regex Expression ^)
This test is to help with the Regex when the symbol is ^ and looks for text which starts with ^
Change the box above to have the word ^Text and it will match the first example.
-------------
Text ends with (Regex Expression $)
This test is to help with the Regex when the symbol is $ and looks for text which ends with xxxxx$
Change the box above to have the word example$ and make sure that you are looking at the multi-line add this in the text field at the top near the g (will not be relevant for URL) and it will match the last example
';
my $regex = qr/the/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}