use strict;
my $str = '1D5Y4D2M';
my $regex = qr/(?<=(?:D|Y|M))/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";