using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":oute: ((?:.(?!:))+)";
string input = @":abd: 576892034 :erg: 94856023MXCI :oute: A RF WERS YUT :oowpo: 649217349GBT GB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}