# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=Total\sDue).*"
test_str = (" Invoice\n\n"
"From: Invoice Number INV-3337\n"
"DEMO - Sliced Invoices Order Number 12345\n"
"Suite 5A-1204 Invoice Date January 25, 2016\n"
"123 Somewhere Street Due Date January 31, 2016\n"
"Your City AZ 12345 Total Due $93.50\n"
"admin@slicedinvoices.com\n\n"
"To:\n"
" Paid\n"
"Test Business\n"
"123 Somewhere St\n"
"Melbourne, VIC 3000\n"
"test@test.com\n\n"
" Hrs/Qty Service Rate/Price Adjust Sub Total\n"
" 1.00 Web Design $85.00 0.00% $85.00\n"
" This is a sample description...\n\n"
" Sub Total $85.00\n"
" Tax $8.50\n"
" Total $93.50\n\n"
"ANZ Bank\n"
"ACC # 1234 1234\n"
"BSB # 4321 432\n\n"
"Payment is due within 30 days from date of invoice. Late payment is subject to fees of 5% per month.\n"
"Thanks for choosing DEMO - Sliced Invoices | admin@slicedinvoices.com\n"
"Page 1/1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.