$re = '/^([^+]+)/m';
$str = '0+171235652++zu
122+115166747++en';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);