$re = '/(?<!!)\b(\w+);/';
$str = '1cat;2dog;!3monkey;!4horse;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);