re = /(\S+)=["']?((?:.(?!["']?\s+(?:\S+)=|[>"']))+.)["']?/
str = 'input type="hidden" name="transactionId" id="transactionId" value="IS2301066344"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end