import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\{(?!p\\.)([^\\}]*?\\.(?:description|input|label))\\}";
final String string = "${person.label} ${taco.input} ${person.description}\n"
+ "${p.person.label} ${taco.something} ${test-dash.description} ${test_underscore.input} ${999.label}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}